[Starlingx-discuss] Using NVME Disks instead of SD

Saul Wold sgw at linux.intel.com
Mon Jan 13 21:03:29 UTC 2020


I have been trying to get a NUC based deployment work, with Erich's help 
we managed to start with a pair of Skull Canyon NUCs running Duplex 
controllers.  This NUC has a pair of Ethernet ports and can be 
configured with 2 NVME-based disks.

I was able to get the devices booted initially with changes to the ISO 
first by hardcoding /dev/nvme0n1 in metal/bsp-files, later Don's tool 
helped address alternative boot_device and rootfs_device setting, but I 
am not sure it went far enough. Erich figured out that we needed to 
patch the sysinv sqlDB (by hand) in order to unlock and make the second 
controller usable.

I went a little further and tried to hook up both work and storage nodes 
to create a 2+2+2 Standard lab, I had to hand edit the PXE boot cmdline 
and also do the sysinv SQL magic to unlock the compute and storage 
nodes, but the Storage configuration still failed.  I am thinking there 
is still some hardcode "sda" and/or "sdb" in places.

Any thoughts on how to enable the Storage nodes properly?  I can provide 
logs, configs, ...

I realize this is a problem at initial ISO boot/install to select the 
drive type, but from there is should be automagically detected on the 
target, so it would require setting the drive type of the host at the 
same time as setting the personality so that the anaconda at least knows 
where to start installing. It may be possible for anaconda to determine 
the drive time also.

Should this be a story, launchpad bug or a Spec to allow use to properly 
use NVME devices with StarlingX. Or is this a solved problem that lacks 
proper documentation? Yes, we discussed some of this last March, but I 
guess it's still a problem and I think it's only going to become more 

Thoughts, direction welcome.


More information about the Starlingx-discuss mailing list