[Starlingx-discuss] Download images and push to local registry Failed

Longqian Zhao zhaolongqian456 at 163.com
Sat Apr 17 05:01:17 UTC 2021


I have successfully solved the following problem. The cause of the problem is a network problem:

Solved problem:
I according to https://docs.starlingx.io/deploy_install_guides/r4_release/virtual/controller_storage_install_kubernetes.html, Task [common/push-docker-images: Download images and push to local registry] runs for 40 minutes without results. I didn't have enough patience to continue waiting and stopped the `ansible-playbook` task. Could you please help me? Thanks.

Brief Description
My Environment:
1. I install StarlingX in Virtual Environment.
2. StarlingX version: R4.0
3. stx-tools: master
4. docker.elastic.co network delay: about 230ms (using ping docker.elastic.co)
5. Steps:
             a. Set system password succesfully.
             b. Run following script in console:
                        export CONTROLLER0_OAM_CIDR=
                        export DEFAULT_OAM_GATEWAY=
                        sudo ip address add $CONTROLLER0_OAM_CIDR dev eth1000
                        sudo ip link set up dev eth1000
                        sudo ip route add default via $DEFAULT_OAM_GATEWAY dev eth1000
             c. cp /usr/share/ansible/stx-ansible/playbooks/host_vars/bootstrap/default.yml $HOME/localhost.yml
             d. modify and add following informations in $HOME/localhost.yml:
                        system_mode: duplex
                        admin_password: Password123$%^
                        ansible_become_pass: Password123$%^
             e. ansible-playbook /usr/share/ansible/stx-ansible/playbooks/bootstrap.yml

1. When I run `ansible-playbook /usr/share/ansible/stx-ansible/playbooks/bootstrap.yml`, the task `[common/push-docker-images: Download images and push to local registry]` will always stay here for a long time.
2. I don’t know if the download speed of docker is too slow, or if I need to wait longer, maybe 2 hours or 5 hours.

Best regards with you,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.starlingx.io/pipermail/starlingx-discuss/attachments/20210417/77060948/attachment.html>

More information about the Starlingx-discuss mailing list