[Starlingx-discuss] Can not launch instance

Gauld, James James.Gauld at windriver.com
Thu Nov 15 14:24:00 UTC 2018

The nova-scheduler.log indicates rejection reasons per host as they get filtered out for various reasons.  They look like this: '<timestamp> <FilterName> (compute-x) REJECT: <message>'.  From your pastebin result, I only saw the RetryFilter.

You got "SCHED: PASS. Selected compute-x", that means it actually attempted to launch on that compute. There is something failing during the launch on the compute, so you get scheduling retries on other computes. That is why you see messages like "RetryFilter: (compute-1) REJECT: Previously tried: [[u'compute-0', .."

Log into each compute and look for error/exceptions in /var/log/nova/nova-compute.log at the specific timestamp of launch.   A similar error message will likely present in the nova-conductor.log (on the controller).  Depending on the specific error, you may need to dig into other logs on the compute (eg, /var/log/kern.log, /var/log/libvirt/qemu/instance-<x>.log, /var/log/libvirt/libvirtd.log, /var/log/openstack.log, etc). This should give hints.  Some of the logs are extraneous noise, so focus near the exact timestamp.


From: von Hoesslin, Volker [mailto:Volker.Hoesslin at swsn.de]
Sent: November-15-18 5:25 AM
To: starlingx
Subject: Re: [Starlingx-discuss] Can not launch instance

cool, thanks for your feedback! i've already read and understood the topic with the backing. i'm now so far that it seems to work if I create an instance without the security-groups (default-group) specification, i don't know why exactly. as far as i've understood it now, it's supposed to have something to do with "port-security-enabled=false"?

sorry that i got in touch with the group so quickly before i exhausted all my possibilities... I promise improvement ;)

Von: Dinescu, Stefan [mailto:Stefan.Dinescu at windriver.com]
Gesendet: Donnerstag, 15. November 2018 11:15
An: volker.von.hoesslin at gmx.de; starlingx
Betreff: Re: [Starlingx-discuss] Can not launch instance


Just a few quick questions to eliminate some potential issues (or maybe even figure out the issue):
1. Are the storage nodes in an available state?
2. On the compute nodes, is nova-local configures for remote backing as well? To check use "system host-lvg-show compute-0 nova-local" and check the "instance_backing" parameter.
From: volker.von.hoesslin at gmx.de [volker.von.hoesslin at gmx.de]
Sent: Thursday, November 15, 2018 11:03 AM
To: starlingx
Subject: Re: [Starlingx-discuss] Can not launch instance
ok, after download the first official ISO (Cengn-mirror) and reinstall the complete starlingX i got the same error. for now, i can see some lines in "/var/log/nova/nova-scheduler.log". i have pasted here: https://pastebin.com/TbvYwTqu

i really need a running openstack and i am willing to spend money for service, please help me guys...


i don't understand that, either i am the only one who builds a starlingX-stack at all or i have to fight very hard for all the additional knowledge i need in addition to the install-doku...
now i have created all necessary components:
- external network
- internal network
- router (add external and internal network)
- add flavoir (aggregate_instance_extra_specs:storage=remote)
- add image (cirrOS 0.4.0 RAW/QCOW2)
- add key pairs
now i created a new instance (via horizon/CLI), without success. the instance is created but it ends in an error-stat :( error messages in the horizon GUI are meaningless for me:

Message: No valid host was found. There are not enough hosts available. compute-0: (RetryFilter) Previously tried: [[u'compute-1', u'compute-1'], [u'compute-0', u'compute-0']], compute-1: (RetryFilter) Previously tried: [[u'compute-1', u'compute-1'], [u'compute-0
Code: 501
Details: compute-0: (RetryFilter) Previously tried: [[u'compute-1', u'compute-1'], [u'compute-0', u'compute-0']], compute-1: (RetryFilter) Previously tried: [[u'compute-1', u'compute-1'], [u'compute-0', u'compute-0']]
Created: Nov. 13, 2018, 11:49 a.m.


Alarm UUID: 15f5bc85-de93-4109-a278-425bafc7c997
Alarm ID: 700.001
Severity: critical
Alarm State: set
Alarm Type: processing-error
Timestamp: Nov. 13, 2018, 11:49 a.m.
Entity Instance ID: tenant=571bfa02-4736-4359-a15d-871224b3b202.instance=3ef09380-47e6-479a-91cc-6813474a183d
Entity Type ID: tenant.instance
Probable Cause: underlying-resource-unavailable
Proposed Repair Action: Manual intervention required
Service Affecting: True
Management Affecting: True
Reason: Instance foobar123 owned by admin has failed to schedule

Interesting is, half of the instance is missing: @see: https://imgur.com/a/UVmEZhF
- missing NIC
- missing IP Addresses
- missing Security Groups
- missing Volumes Attached

does anyone still have a tip for me? Volker

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.starlingx.io/pipermail/starlingx-discuss/attachments/20181115/486a7571/attachment-0001.html>

More information about the Starlingx-discuss mailing list