[Starlingx-discuss] which version is working for devstack support?

Huang, Marvin Marvin.Huang at windriver.com
Tue Nov 27 20:42:02 UTC 2018

Hi all,

I hit issues when tried to bring up stx-conf with devstack using the local.conf at https://wiki.openstack.org/wiki/StarlingX/Devstack/stx-config.

I was following the DevStack procedures but using the above configuration file.
One problem is:
    ++functions-common:git_clone:568            cd /opt/stack/devstack
    ++/opt/stack/stx-config/devstack/lib/stx-config:install_stx_utils:123  pushd /opt/stack/stx-utils/middleware/util/recipes-common/platform-util/platform-util/
    /opt/stack/stx-config/devstack/lib/stx-config: line 123: pushd: /opt/stack/stx-utils/middleware/util/recipes-common/platform-util/platform-util/: No such file or directory
+/opt/stack/stx-config/devstack/lib/stx-config:install_stx_utils:1  exit_trap

I also tried with latest STX_BRANCH by comment off the line in local.conf

But the same problem was hit.

Anybody has any idea what's the status of DevStack support for STX? Where can I find more information besides https://wiki.openstack.org/wiki/StarlingX/Devstack/?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.starlingx.io/pipermail/starlingx-discuss/attachments/20181127/4545749e/attachment-0001.html>

More information about the Starlingx-discuss mailing list