[Starlingx-discuss] controller-1 install/setup using ISO (not pxe)

Pratik M. pvmpublic at gmail.com
Thu Sep 19 08:58:42 UTC 2019

I have installed controller-0 and my OAM_IF is eno1 and MGMT_IF is
eno2. I am trying to install controller-1. However, my existing OAM
lab network already runs pxe. And my server BIOS does not have an
option to select one specific network interface for PXE booting.

So I tried to temporarily switch the cables (connect mgmt to eno1 and
disconnect oam). The pxe boot works; controller-1 gets discovered. And
I can do host-update 2 personality=controller. After the install and
reboot, I switch back the cables. And try to set the OAM_IF to the
correct/final interface (eno1).
[sysadmin at controller-0 etc(keystone_admin)]$ OAM_IF=eno1 && MGMT_IF=eno2
[sysadmin at controller-0 etc(keystone_admin)]$ system host-if-modify
controller-1 $OAM_IF -c platform
Interface not found: host controller-1 if eno1

I see the controller-1 does not have an IP post reboot. I tried
manually setting the eno2 IP to but still it shows

[sysadmin at controller-0 ~(keystone_admin)]$ system host-list
| id | hostname     | personality | administrative | operational |
availability |
| 1  | controller-0 | controller  | unlocked       | enabled     |
available    |
| 2  | controller-1 | controller  | locked         | disabled    |
offline      |

I cannot reverse the cabling on the NICs for a different set of reasons.

Any workaround? Is there a way to install the software using iso, set
some IPs manually and then enroll the controller-1 to the cluster?

Thanks in advance

More information about the Starlingx-discuss mailing list